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Introduction
SimpleTrack provides task tracking functionality with the look, feel and simplicity of sticky notes. As
such, it
•
•
•

uses only a small amount of screen real estate;
allows a new task to be created in seconds;
supports typical sticky note colors,

while in addition, it
•
•
•
•
•

automatically marks the date and time of a new task;
allows tasks to be marked as completed with a single click;
automatically marks the date and time of task completion;
automatically removes completed tasks from the list;
allows review of all completed tasks.

Those are the basics: the app is simple, and it tracks dates, times and status.
While offering a slew of additional functions, introduced below, SimpleTrack has a few restrictions
compared to other sticky apps; these include:
•
•

the horizontal window size is fixed; the window can only be resized vertically;
only a single app instance can run, so there cannot be multiple SimpleTrack windows on screen.

Installation and first use
SimpleTrack was designed for Microsoft Windows 10 and is installed by running SimpleTrack Setup.exe.1
Upon first use, the End User License Agreement is shown:

1

SimpleTrack is compatible with .NET Framework 4.6 and higher. This framework comes with Microsoft Windows;
version 4.6 corresponds to the first release of Windows 10 (v1507). At the time of writing, the current version is
.NET 4.7.2 (Windows 10 v1803). Other versions can be downloaded for free from the Microsoft website.
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Hit OK to continue; this brings up the Options form below. To get started, enter a user name and hit the
Set button. You can also choose if you want SimpleTrack to start with Windows and if you want it to
always be on top of other Windows. These choices can easily be changed later. Hit OK to close the form
and bring up the main window.

Tasks and lists
Before introducing the SimpleTrack window, the concept of a Task has to be introduced. Basically, a task
is a single item on a to-do list. Each task has the following attributes:
•
•
•

•
•
•

A description.
An urgency status (normal or urgent).
A set of dates that indicate the progress status:
o Created: the date a new task was created; automatically assigned.
o Target: the target completion date (optional).
o Started: the date the task was marked as started.
o Completed: the date the task was marked as completed.
An optional reference code: a brief code for linking the task to other planning tools, if so desired.
An optional comment.
An identifier (automatically assigned; used to order tasks).

The SimpleTrack window is essentially a list of tasks, and the app supports multiple, independent tasks
lists. Each task list or simply list is basically a to-do list. The only attributes of a list are its name, the
tasks it contains, and its color. Lists can be created, selected, renamed and deleted. Tasks are created on
the currently selected list and can thereafter be modified; copied or moved between lists; and deleted.

Window modes
Upon first use, the main SimpleTrack window looks like the left screen shot below. Only a few essential
attributes are visible: Task, Urgent (!), and Completed (✓). Also visible is the Menu Bar, which will be
explained in detail below. Note that the window does not have the typical Windows Title Bar. This bar is
available though, and can be shown or hidden via the View menu (View → Title Bar) or by typing Ctrl+T.
With the title bar visible, the window looks like the screen shot on the right. Default in the title is the
name of the initial task list; To-do indicates that you are viewing tasks that have not yet been completed.
Completed tasks can be viewed via View → Completed or Ctrl+C, and are indicated as Done.
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The Menu Bar can be hidden or shown via View → Menu Bar or Ctrl+M. In addition, there is a List Bar
that can be shown or hidden via View → List Bar or Ctrl+L. The screen shots below show the SimpleTrack
windows with the least top bars on the left and the most top bars on the right, respectively.

The main part of the SimpleTrack window consists of a data grid with rows and columns. The
intersection of a row and column is called a cell. No cells were selected in the first two screenshots,
while the default cell for adding a new task is selected is shown in the last two screenshots. Selected
cells are shown in blue, unless they are being edited. Clicking a cell puts it in edited mode; this will show
the cursor (|), indicating that you can start typing. You can also just start typing without clicking the cell
first.
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The text that is typed gets submitted to the database by hitting Enter, while hitting Escape will cancel
any edits and change the cell back from edit mode to merely selected. Note that the Menu Bar is
disabled while editing; it gets re-enabled after hitting Enter or Escape.
Any of the above windows can be expanded to expose the remaining task attributes via View → Wide or
Ctrl+N. The screen shot below gives an example of this wide mode, with the Menu Bar visible.

Moreover, any of the above windows can be vertically resized, but only when the title bar is visible. They
can also be moved across the screen; to do so when the title bar is hidden, click on Task, then drag.

Basic use
A new task can be created by simply typing its description in the Task column in the first available row,
which is the row just below any tasks that were previously created. Multi-line task descriptions are
allowed: descriptions can be up to 1024 characters long. Hitting the Enter key after typing a description
sets its Created attribute to the current date and adds the task to the database.2
Let’s hide the Title Bar again and then enter a few test tasks:

The last task has been marked as in progress via Task → Start or Ctrl+S after entering the task
description. Wide mode reveals what attributes have been set. All tasks have a Created date, while the
last task also has a Started date.
2

SimpleTrack uses a SQL Server Compact Edition database, which is a file called SimpleTrack.sdf that is by default
stored in [CommonApplicationData]\Sunny Side Up Software\SimpleTrack\. On Windows 10,
[CommonApplicationData] typically equals C:\ProgramData\.
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Going back to narrow mode (via View → Narrow or Ctrl+N) and then marking the urgent task as
completed (by clicking the checkbox in the ✓ column) gives

Notably, the completed urgent task has disappeared, as it no longer belongs in the To-do view. Tasks
that have been completed can reviewed via View → Completed or Ctrl+O; for our example, that gives

Going to wide mode reveals that the completion date has been documented:
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The information in the Completed view is read-only; no changes can be made, and no new tasks can be
added. In case changes to a completed task are needed however, it can be re-opened by clicking the
checkbox in the ✓ column.3 This removes the Completed date and moves the task back to the To-do
view.
In the To-do view, the selected task can be deleted via Task → Delete or Alt+J, or by simply hitting the
Delete key. In the Options form (available via File → Options or Alt+O, and shown on page 3), you can
specify if SimpleTrack should ask for confirmation before deleting a task and if deleted tasks should be
archived. In the latter case, the task will be marked as deleted but kept in the database.
Any action that changes the database can be undone via File → Undo or Ctrl+Z; up to five undo steps are
supported.
A final basic use topic is that the window background color can be changed via View → Color → <color>
or via Alt+B, Alt+G, Alt+P, Alt+W or Alt+Y (for Blue, Green, Purple, White and Yellow, respectively). The
screenshots depict the various options.

Rearranging and sorting tasks
The tasks in a list can be rearranged, for example, to put those you consider most important at the top
or bottom of the list, depending on your preferences. Moving a task up or down in the list can be done
in two ways: via Ctrl+U (for up) or Ctrl+D (for down), and by drag and drop. The former will move the
selected task one position up or down; the latter will insert the dragged task at the location where it is
dropped. In the list below, for example, pressing Ctrl+U three times moves task 8 up by three, as shown

in the screenshot below. Note that the numbers in the ID column haven’t changed! The reason is that a
task’s ID is not a fixed number belonging to that task, as the name might suggest; instead, it is used to
remember task’s location in the list. This was done for the following reason. Tasks can be sorted by any
of their attributes, simply by clicking on the corresponding column header. This can, for example, be

3

There is no associated Menu Bar command.
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used to quickly find the newest or oldest tasks, or the tasks that need to be completed first. Left-clicking
on a column header once will sort in one direction; left-clicking again will sort in the other direction.
Note that right-click must be used to sort the Task column; this is because left-click is reserved for
moving the SimpleTrack window when the title bar is not visible.

As an example, the screenshot below is the result of right-clicking on Task, which sorts the list by task
descriptions in alphabetical order:

Note that the ID column has changed this time. Left-clicking on Target gives:

Sort Task column via right-click
Ctrl U/D; drag/drop; click column header

Any column except Done
Cannot sort tasks in All list
Left-clicking on ID sorts by task position, which results in the original task order shown at the top of this
page.4

4

Note that re-arranging tasks via Ctrl+U/D or drag/drop while the list is sorted will change the original tasks
positions, which can then no longer be restored. In order to keep these original task positions, for example, to use
them as urgency indicators, make sure to sort by ID prior to re-arranging tasks.
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Task lists
Task lists, introduced above, offer a way to organize tasks into categories, with each list representing a
category. When SimpleTrack is used at home, categories for can, for example, be something like
Groceries, Bills, Vacation, Social, Work; for office use, they could be something like General, Admin,
Project 1, Project 2, Private.
When SimpleTrack is first started, there is just a single list, called Default; it can be renamed via List →
Rename or Ctrl+R. More lists can be added via List → New or Alt+N. The name of a new list must be
unique; duplicate list names are not allowed. Lists can be added whether or not the List Bar is visible.
Once there is more than one list, an additional list named All is automatically added. This list, when
selected, shows the tasks of all lists merged into one, ordered by their Created date.
Time for an example. Let’s assume we use the same computer at home and at work, and we want just
two lists: Home and Work. We get the first one by renaming the Default list and create a new list for the
second one. With the List Bar visible and no tasks yet, the window looks like the screen shot below.
Note:
•
•
•

the automatically added All list;
the black border around the Home tab which indicates that this is the current/active list;
the disabled  and  buttons on either side of the List Bar; these get enabled when there are
more lists names than fit in the bar, so as to allow scrolling among these lists.

A list other than the active list can be selected via View → List → <name> or by clicking the list’s tab in
the List Bar, if visible. Now let’s add some tasks to each list and pick a color for them:
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The All view, also given its own color, looks like this:

It is possible to move or copy tasks from one list to another. This can be done in two ways: via the Menu
Bar (Task → Move To → <list> and Task → Copy To → <list>, respectively) and by means of drag and
drop. Dragging a task description to a tab in the List Bar moves it to that list; doing the same while
holding the control key down copies it to that list. In the Options form (File → Options or Alt+O) you can
specify if a task move should be confirmed or not. If not, the task will be moved without question; if so,
you will be asked to confirm the move via a pop-up window. If you decline, the move will be canceled.
Unless the current is the All list, it can be deleted via List → Delete or Alt+Q; you will be asked to confirm
this action. If the task archiving option is enabled, the tasks of a deleted list will be kept in the database.

Collaboration
In keeping with its name, SimpleTrack offers a simple form of multi-user collaboration. There are two
prerequisites for the SimpleTrack app of user 1 on computer 1 to connect to the SimpleTrack app of user
2 on computer 2:
1. The two computers can directly connect to one another over a network, via TCP/IP.5
2. User 1 has given user 2 rights to access one or more of his or her lists, and/or vice versa.
A detailed discussion of point 1 is beyond the scope of this document; suffice it to say that if both users
are on the same home or office network, collaboration most likely is possible, while collaboration
between a user at home and a user at the office most likely is not.
Regarding point 2, the first step for user 1 (let’s call her Alice) to request access to the SimpleTrack data
of user 2 (let’s call him Bob) is to enable the Share selected lists option in the Options form. If Windows
Firewall – or an alternative firewall – is enabled on Alice’s computer, a window may come up asking if
SimpleTrack can be given access to communicate through the firewall; that access must be provided to
allow communication with Bob’s computer.
5

See the section on Design Considerations.
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The next step is to for Alice to copy her connection string to the clipboard by hitting the Copy button in
the Options form,6 and then pasting that string into an email to Bob, possibly along with an explanation
of her request. If Bob decides to accept Alice’s request, he should also enable the Share selected lists
option and then grant Alice access to one or more of his lists, which he can do so via User → Grant
Access… or Alt+T.7 That brings up the following form:

Bob now copies the connection string from Alice’s email message onto his clipboard, pastes it into the
text box at the top of the form, and hits Enter; that gives

Bob can now decide which of his two lists he wants to give Alice access to. Let’s say he provides access
to both by clicking Select All. Bob is also interested in having access to Alice’s SimpleTrack data, which he
can request via Request access from this user. He then submits his choices by hitting OK. Alice, assuming
she is online and her SimpleTrack app is running, now sees two windows pop up:

6
7

The connection string contains the following information: <user name>;<user code>@<IP address>:<port>.
The User item appears on the Menu Bar when Share selected lists is enabled.
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Alice closes the first window, then gives Bob access to her Work list in the second window and hits OK.
Bob now sees a message like the one on top informing him that Alice has given him access to one or
more of her SimpleTrack task lists.
Because SimpleTrack uses direct connections between apps and does not rely on a shared server that is
always available, messages cannot be delivered when the recipient’s computer is offline or if his/her
SimpleTrack app is not running. If that is the case, the sending app will queue the messages its wants to
send and periodically try to resend them.
The View → User menu item, disabled until this point, will now be enabled for both Alice and Bob. If, for
example, Bob selects View → User → Alice, and Alice’s SimpleTrack app is online, he will see:
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There is only one list, the one that Alice shared.8 Lists from other users are always shown in gray. Their
data is not stored, and they cannot be modified. There is also no All list. Tasks are retrieved live from the
other user’s SimpleTrack app when one of their lists is selected; in case that app is not live, a message
will appear stating that the requested data is not available.9
When Bob enables the title bar (View → Title Bar), it shows that current data are the To-do tasks of
Alice. Had she also shared her Home list, a Home tab would be visible on the List Bar and the Title Bar
would read Alice : Work : To-do when the Work list was selected, and Alice : Home : To-do when the
Home list was selected.

A few more notes on the collaboration mechanism:
•
•
•

•

8
9

If a user changes his/her name or the name of one of his/her task lists, those names will be
updated in connected SimpleTrack apps next time they try to access the affected list.
It is possible to connect to the SimpleTrack app of another user from another network address
than was used to request access; only the user identifier is used to grant or deny access.
If SimpleTrack receives a data request from a user it has granted access to, and itself has access
to that user’s data, and that user is connecting from a new network address, it will record the
new address. When trying to retrieve data from that user, SimpleTrack will try to connect to any
of his/her known network addresses in order of most recent use.
When changing from viewing/editing one’s own data to viewing the data of another user, all
undo information is cleared; previous actions can therefore not be undone when returning to
one’s own data.

Alice on the other hand will see two list tabs when she selects View → User → Bob, because Bob shared two lists.
That is a consequence of the choice to not have a central task repository.
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Move / switch
The SimpleTrack database (a file called SimpleTrack.sdf) and its backups are by default stored in a
system folder.2 It is possible to move them to a different location in the file system via File → Move or
Ctrl+M. The main purpose of this feature is to provide an easy way to access your SimpeTrack data from
multiple computers, by moving the database to (a subfolder of) the OneDrive folder, which is synced
with any computer you log on to with your Microsoft account.10
Note that after moving the database to another folder, removing or renaming that folder will cause
SimpleTrack to fail. To prevent this, first use File → Move again to move the database to a folder that
will not be affected by the subsequent remove or rename.
To access a SimpleTrack database from another computer, simply use File → Switch, browse to the
OneDrive folder where the database is stored, select the file called SimpleTrack.sdf, and hit OK.
The above database sharing mechanism does not support simultaneous use on multiple machines. To
prevent sync issues, it is recommended to close SimpleTrack on one machine before using it on another.
The app checks once a minute if another instance appears to be active; if so, it warns to close either one
before continuing.
Note that while the data can be shared among computers, several app settings (as per File → Options)
are stored locally and can hence differ per computer. If you want them to be the same everywhere, you
must manually update the settings on each computer.
Finally, note that it is possible to move the database to a network folder. This limits sharing to
computers that are on the same network. If other users have access to the same folder, they will be able
to access your database; so use this possibility with care.

Import / export
SimpleTrack has two ways to export data:
File → Export → Database… or Alt+D
This lets you export the SimpleTrack database. It can be used, for example, to save occasional backups
to a specific location, or to port the database to another computer. Selecting this command brings up a
folder browser; navigate to the desired location in the file system, then hit OK to save the file.
File → Export → To CSV File… or Alt+C
This lets you export the lists and tasks of the current database to a CSV file, which can be imported by
e.g., Microsoft Excel.11 This can be used, for example, for analysis purposes, for example, to calculate the
average time it takes to complete a task. As before, selecting this command brings up a folder browser;
navigate to the desired location in the file system, then hit OK to save the file.

10

OneDrive is a cloud storage service that is part of Microsoft Office. It was previously known as SkyDrive,
Windows Live SkyDrive, and Windows Live Folders. Alternative cloud storage services such as Dropbox can also be
used.
11
CSV stands for comma separated values.
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There is also an option to import databases:
File → Import… or Alt+I
This command brings up a file browser to select a previously exported SimpleTrack database file. Hitting
OK will attempt to replace (!) the current database by the imported one; this will cause the app to
restart. The user is responsible for making sure that the imported file is a valid SimpleTrack file.12

Backup / restore
SimpleTrack automatically backs up its database whenever it detects that a day or longer has elapsed
since the last backup. It is also possible to create a backup on demand, via File → Backup or Ctrl+B. Note
that at most three backups are kept, and each new backup overwrites the oldest one. In case you want
to preserve a particular version of the database, save a copy via File → Export as explained above.
An existing backup can be restored via File → Restore → <date & time>:

After selecting the desired backup, you will be asked if you are sure that you want to replace the current
database by the selected backup. If confirmed, the backup will proceed and cause the app to restart.
The backup you selected will disappear from the list, but any others remain available.

List export
List → Export or Ctrl-E exports the task descriptions of the current list to a user-selected folder as a text
file called <list name>.txt. Choosing a cloud-based folder, e.g., on Microsoft OneDrive, allows the list to
be viewed on mobile devices. Editing an exported list has no effect on the SimpleTrack database.
List → Auto Export or Ctrl-A exports the current list each time a change is made to it. If the list hadn’t
been exported previously, the user is prompted to specify the export folder.
The above features are, for example, handy for maintaining a shopping list.

12

If this action fails for whatever reason: close SimpleTrack; open Windows Explorer; navigate to the database
location; delete SimpleTrack.sdf; rename SimpleTrack1.sdf to SimpleTrack.sdf; restart the app.
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Help
The Help menu, accessible from the upper right of the SimpleTrack window, has the following three
options:
Help → Commands or Alt+Z
Brings up the list of menu commands and the associated keyboard shortcuts shown on the next page.
Help → User Manual or Alt+U
Opens this user manual in the default PDF reader. If no reader is available, an error message appears.
Help → About or Alt+A
Brings up the end user agreement shown on page 2.

Settings
Upon being closed, the SimpleTrack app will remember key user settings such as narrow or wide mode,
list colors, list being viewed, window location and size, etc.
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Command summary
Menu
File

View

Task
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Key
Alt+F

Alt+V

Alt+E

List

Alt+L

User
Help

Alt+U
Alt+H

Submenu
Undo
Move…
Switch…
Import…
Export 

Key
Ctrl+Z
Alt+M
Alt+S
Alt+I
Alt+E

Backup
Restore 
Options…
Exit
Completed
To-do
Narrow
Wide
Title Bar
Menu Bar
List Bar
List 
User 
Color 

Ctrl+B
Ctrl+R
Alt+O
Alt+X
Ctrl+O

Minimize
Start
Move Up
Move Down
Copy To 
Move To 
Delete

Ctrl+
Ctrl+S
Ctrl+U
Ctrl+D

New…
Rename…
Export…
Auto Export
Delete
Grant Access…
Commands
User Manual
About

Submenu

Key

Database…
CSV File…

Alt+D
Alt+C

<date & time>

Ctrl+N
Ctrl+T
Ctrl+M
Ctrl+L
<list name>
<user name>
Blue
Green
Purple
White
Yellow

<list name>
<list name>
Alt+J
DEL
Alt+N
Alt+R
Ctrl+E
Ctrl+A
Alt+Q
Alt+T
Alt+Z
Alt+U
Alt+A

Alt+B
Alt+G
Alt+P
Alt+W
Alt+Y

Design Considerations
SimpleTrack was created with the following in mind:
Features:
•
•
•
•
•
•

Easy to use.
Automatic tracking of important dates.
Small screen real-estate.
Not strict: no data is permanently frozen, anything can be changed.
Simple collaboration support: tasks of other users on same network can be viewed by permission.
Limited mobile device support: desktop app can export task lists to a cloud folder for viewing as text
file.

App:
•
•
•
•
•
•
•
•

Windows 10 desktop app.
Stand-alone; no dependencies.
No security concerns; no logon, encryption etc.
Single user per machine.
Multi-machine access via cloud folders (Microsoft OneDrive or similar).
Collaboration via peer-to-peer socket connections; no central storage, no web server.
Peers addressable by network address: <IP address>:<port>.
Multiple network addresses allowed per user.

End User License Agreement
SimpleTrack is provided as FREEWARE for any type of use. It is provided as-is; there is no warranty of any
kind. The database format of future releases may not be backwards compatible.
By using the app, you agree to not hold the author liable for any adverse events related to its use.
Copyright © Kees van Zon 2017-2018. All rights reserved.
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